satria neo engine stalled on heavy rains when a/c compressor turned on

  • '(00): currently testing temporary changes to the site and ad serving, sorry for any weirdness experienced, people! Please do send any feedback here: Contact us
Oct 29, 2014
4
1
503
Kuala Lumpur
Does anyone ever heard or experienced it?
Have taken the car to COE (they kept for few days), other proton SCs, auth a/c sc etc. None seems to able to rectify the cause.
Symptom: engine stalled during heavy rains or after sending for car body wash whenever the compressor turned on. But if only fan on, engine is fine.
One auth a/c sc has ruled out compressor locked nor problem with a/c system after doing thorough checking including disconnect the compressor connector. Engine still stalled.
Few mechanics got the throttle body clean etc-etc, still problem there.
Some sc even wrapped the connector near harness & fuse box with plastic, still no luck. Ahahaha, worth trying as opposed to COE.
Sending to COE was total craps as after few days holding my car, they said there was nothing problem. ECU also found good. :(
It can caused an accident while driving under heavy rains when the car suddenly engine die. Ppl inside also if not lucky die too. Haiyooo....
Please help sharing info etc if u do know one.
Thank you.
 

gunnerzz

2,000 RPM

gunnerzz

2,000 RPM
Jul 3, 2014
2,089
684
713
37
Melaka
1.Seem like a wiring issue as it does not happen when its hot and dry.
if u install any electrical gadget to your car,double check the wiring job.

2.Try swapping the aircond relay.

3.If this problem on happen after u install something on the car then have that part checked or just removed it.

4.Blow the fusebox with airgun
 

stin6ray

Thread starter
Oct 29, 2014
4
1
503
Kuala Lumpur
hi gunnerzz,
yeah, wiring is the one suspected the caused. however, few wiremens have failed to identify which one as most of them.found still in good condition.
nope, I have not installed any gadget or what not since I bought the car. Am d 1st owner though.
yuppe, am planning to swap the relay tis weekend. Have gotch it checked before, and still good according to the wiremen/mechanics. well, worth trying yea.
we have got the fusebox blowed too. no luck. then decided to wrap with plastic before its cover.

Thank you gunnerzz. will keep posted whatever d results be.
wish me luck ;-)
 

Izso

NA NA NA NA NA
Helmet Clan
Moderator

Izso

NA NA NA NA NA
Helmet Clan
Moderator
Mar 28, 2004
15,372
6,406
5,213
KL
Only when raining? Sounds like a short circuit somewhere caused by rainwater? Strange COE couldn't troubleshoot it though.
 

stin6ray

Thread starter
Oct 29, 2014
4
1
503
Kuala Lumpur
Hi Speedo,
sorry am not sure which one thou :(
mine is the entry level 1.6 manual model. Guess among d 1st batch.
I think it waa not fitted w r3s.

Yeah, Iszo. It surprised me too. Almost exploded too when they said there was nothing wrong w my neo.
Looks like am purposely created something not existed. I still keep the work order.

Well, anyway....have tried so many options still to no avail.
Now, what I did as still doing is to put a tape along the openings area on the hood - to prevent rainwater or car bodywash from seeping thru.
But it sure look ugly like beauty & d beast. :D
Have to do dressing every alt day. :(
 

^pomen_GTR^

7,000 RPM
Senior Member

^pomen_GTR^

7,000 RPM
Senior Member
May 13, 2010
7,509
1,690
1,713
The Mines
Hi Speedo,
sorry am not sure which one thou :(
mine is the entry level 1.6 manual model. Guess among d 1st batch.
I think it waa not fitted w r3s.

Yeah, Iszo. It surprised me too. Almost exploded too when they said there was nothing wrong w my neo.
Looks like am purposely created something not existed. I still keep the work order.

Well, anyway....have tried so many options still to no avail.
Now, what I did as still doing is to put a tape along the openings area on the hood - to prevent rainwater or car bodywash from seeping thru.
But it sure look ugly like beauty & d beast. :D
Have to do dressing every alt day. :(


try ask them drive on water puddle at the coe to prove they were right "no problem" assumption....
 

slipar

500 RPM
Senior Member

slipar

500 RPM
Senior Member
Apr 29, 2006
500
61
1,528
banting - pj
a bit same happen to my brother wira..not neo but maybe can narrow down your problem..when water touch distributor cap the engine die..pelik also..try to spray water also same..engine die after water touch distributor cap..change cap problem solve..dont really know what the problem..small current leak maybe..

u can try to spray water to ur engine while running..or engine part by part to search the cause of the problem..be extra carefull water to engine also dangerous..
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,938
8,365
1,713
Petaling Jaya
Usually even if distributor leak the engine should misfire and not die off. I have leaking spark cable, cracked distributor and even leaking coil, it just misfire and have loss of power.

---------- Post added at 10:05 PM ---------- 6 hour anti-bump limit - Previous post was at 09:56 PM ----------

a bit same happen to my brother wira..not neo but maybe can narrow down your problem..when water touch distributor cap the engine die..pelik also..try to spray water also same..engine die after water touch distributor cap..change cap problem solve..dont really know what the problem..small current leak maybe..

u can try to spray water to ur engine while running..or engine part by part to search the cause of the problem..be extra carefull water to engine also dangerous..
I do wash my engine once in a while, since I know my ECU is in the passenger compartment, but to spray water with engine running, I don't do that.....hhahahhah:biggrin:
 

gunnerzz

2,000 RPM

gunnerzz

2,000 RPM
Jul 3, 2014
2,089
684
713
37
Melaka
last time when i saw water puddle on the road i will be very careful if the water is on the left side.
i will slow down to safe pace before going through it.
if its on the right side then no need to slow down.
why?
because my gb modular connector is behind the gb and its on the left/passenger side.
if it gets wet, gb light will lit up and in worst case gb will act weird.

maybe u can use this method or the people at proton should try this to pin point the cause.
a friend with a persona once have this gb jerking problem and it was traced to a loose lamp wiring.such is the sensitivity of electronic part and wiring.

another thing to share is with my waja.engine hessitate during accelerating.even proton cant trace the problem and suggest replacing the ecu.
after checking, found that one of the 3 connector to te ecu has its seal worn out and causing water to slip in and shorting 2 pin.
thats it,2 pin and the car behave weird.i just clean the pin and relocate the ecu in the engine bay with protection all around.
never encounter the problem again.

which led to think that yours is probably just a current leakage.have to trace the wiring in the engine bay one by one....very time consuming.