need help..please

fazidk

3,000 RPM
Senior Member

fazidk

3,000 RPM
Senior Member
Nov 18, 2003
3,163
413
5,183
All forummers/experts/sifus

i was hoping that you will be able to
assist/troubleshoot/advice me on this small but
iritating problem i am facing

im currently driving a 1G 4g63t. so far the engine is
fine though im planning to really upgrade it for race
usage. but for now i have to settle with its not-so
original state. my problem is the RPM meter. the car's
idling is fine but the RPM goes unstable. at times
when the car is moving, say, at 100km/h, the rpm goes
accordingly and then drops to zero!! this is not
permanent as it will go up again and then drops again
etc etc...i hope this you can visualise or understand
my explaination...

i went see a mechanic and he says that its the
MITSUBISHI POWER UNIT thingy (i enclose the picture as
attached)which is faulty but before i got it replaced
i went to get a second opinion from my regular mech
and he says that the item is not faulty!! he says its
got something to do with my earth wiring. is this true
in your expert opinion?

your soonest reply is higly appreciated.

thank you and best regards
 

zakie

Known Member
Senior Member

zakie

Known Member
Senior Member
Jul 7, 2005
131
0
1,516
Kuala Lumpur
try 1st, coz mine oso got the same probLem wHen 1st iNstaLLatioN....
after cHaNgiNg tHe aLL tHe wiRiNg & eCu, mY car performaNce got better...

NormaL Laaa, its a coNvert tHiNgs..... tHe eNgiNe u bouGht fr tHat 'kedai potoNg' sure oLd oredi, so u Have 2 cHaNge eveRy siNgLe tHiNgs..... iN order 2 make it ruN properLy... hehheeheheee......
 

fazidk

3,000 RPM
Senior Member

fazidk

3,000 RPM
Senior Member
Thread starter
Nov 18, 2003
3,163
413
5,183
oh ok guys...thnks 4 ur suggestions....so u mean 2 say dat it may NOT b dat black box problem??wat cld it b then?coz i dont wanna get it replaced n d problem still there...since u guys faced d problem b4 wat is it dat u did 2 solve it?

thnks