idling too high

xinghonh

1,000 RPM
Senior Member

xinghonh

1,000 RPM
Senior Member
Aug 25, 2006
1,415
7
1,638
hi bro
im having this prob where my idling is at 1.5k rpm
i tried adjusting the throttle body by screwing tight to the max
and yet the problem still cant be solved
plz help me~!!
 

allance

Known Member
Senior Member

allance

Known Member
Senior Member
May 12, 2009
337
8
1,518
when u got this problem frist? ok! ....i think myb ur vacum hose is leak! pls checking
 
Last edited:

nezumi

Junior Member
Senior Member

nezumi

Junior Member
Senior Member
Jun 18, 2007
21
0
1,501
40150
daiichi-ketsui.com
could be broken tps...

i had d same prob... changed afm, changed aac, changed ecu... nada! still idled high...

yup, it was d bloody tps... when i pulled the tps socket towards me, the idle dropped to normal...

temporary, i used a 15mm bolt & put it in between the tps socket and the intake pipe connecting hose dat leads to the throttle body... well, it's ok now ;-)

dunno 'bout u, mine is d rb20det...

hope this helps...
 

xinghonh

1,000 RPM
Senior Member

xinghonh

1,000 RPM
Senior Member
Thread starter
Aug 25, 2006
1,415
7
1,638
haha correct...its 4g93 bot
i heard sumthin bout tps where they can use a machine to reset it?
 

nezumi

Junior Member
Senior Member

nezumi

Junior Member
Senior Member
Jun 18, 2007
21
0
1,501
40150
daiichi-ketsui.com
haha correct...its 4g93 bot
i heard sumthin bout tps where they can use a machine to reset it?
i'm not familiar wif d 4gxx series engines...

on rb engines, all u need is a digital multimeter... and set the tps within d specified range, which is between 0.45-0.50 volts... a very-very simple job...

should be similar to setting the tps on other cars... correct me if i'm wrong...
 
Last edited: