HELP! Wira Idling problem, mmc model

sooyongng

Junior Member
Senior Member

sooyongng

Junior Member
Senior Member
Jun 16, 2010
5
1
503
Kuala Lumpur
Hi,
Anyone could help me out? regarding wira mmc idling issue.

Problem: Idling, it rev at 800-900. When engine is hot. Rev continuously, 800-900-800-900......aircond ON also same. but not so noticeable.
When occur: After head gasket replacement, and replaced a worn tappet screw.(claimed by workshop that tappet screw cant tightened).

I've adjusted TPS voltage, anything lower than 0.75V, RPM will completely stable, but when aircond ON, RPM drops to 400. (which i dont like).
Then, anything higher than 0.75V, RPM will rev 800-900-800-900, when aircond ON, RPM at 1000, engage D, RPM drops to 700. (which is normal condition)

How come RPM will fluctuate when TPS voltage lower than 0.75v?

What i've done checking:
-TPS sensor, reading is smooth when throttle plate open.
-ISC gear, all teeth no broken or wear. (replaced grease already).
-ISC servo, it's running perfectly when TPS is 0.75v or higher.
-all vacuum hoses connected with TB.
-spark plug and cables.
-Distributor
-MAP sensor
-cleaned TB, took off and cleaned with carb cleaner.

ohya, TPS is built in IDLE switch, ON and OFF condition.
IDLE switch should be ON when idling, at ON position, TPS is 0.45v.
0.75v, IDLE switch at OFF position already.
Even i've set to 0.45v, when aircond ON, RPM will dropped near to stall.

Please enlightened me.
I don't want place back FICD as the RPM will not permanently stay on certain RPM. (sometimes 800, sometimes 500).
 

^pomen_GTR^

7,000 RPM
Senior Member

^pomen_GTR^

7,000 RPM
Senior Member
May 13, 2010
7,509
1,690
1,713
The Mines
check vaccum line may have crack somewhere along the vaccum hose...


and try adjust idle via stopper screw behind the throttle body first..then only compensate with auxilary air-idle screw....


i did exactly that and now rpm was the best and stable no matter a/c on or off....
 

sooyongng

Junior Member
Senior Member

sooyongng

Junior Member
Senior Member
Thread starter
Jun 16, 2010
5
1
503
Kuala Lumpur
I've just wasted RM45 for MUT tuning, the foreman tuned down the TPS voltage from 0.75 to 0.66v, which idle position is ON.

Now whenever ON aircond, RPM will dropped to 400.
While aircond ON, drive and slow down at traffic light, RPM dropped again near to 200!!.

Sigh....no choice, plug back FICD, set to appropriate RPM.


btw, vacuum hoses all in good condition, no crack or break.
and yes, the Fixed sas screw that u mentioned, i got re-screw it according to service manual mirage '93. Yet, the RPM somehow will not stay where it should when AC is ON.
 

^pomen_GTR^

7,000 RPM
Senior Member

^pomen_GTR^

7,000 RPM
Senior Member
May 13, 2010
7,509
1,690
1,713
The Mines
oh btw... mine idle speed was set at +-900rpm.....

slightly higher because can't rely too much on the ISC as the part was prone to break/fault...
 

kayour

Known Member
Senior Member

kayour

Known Member
Senior Member
Apr 5, 2006
326
41
1,528
mine...93p
b4 this using eterna tb
after pening kapala with this of problem...bad idling [turun naik turun naik]...easy to die when aircon on
installed ficd.. tps 0.5-0.6v..rpm 1000-1200...ok la
btw... i removed water cooling pipe
 

sooyongng

Junior Member
Senior Member

sooyongng

Junior Member
Senior Member
Thread starter
Jun 16, 2010
5
1
503
Kuala Lumpur
Now with FICD, and ISC socket still intact.
I think these combination is best for wira.

ohya, question regarding coolant going thru TB.
I've tried bypass it and start engine, it seems RPM takes long time at cold start. Rev ~1500.
But after i plug back coolant hose into TB, start engine, in 10sec, immediately RPM dropped to ~900.
I think there's some sensors for autochoke inside TB. anyone can double confirm this?
 

^pomen_GTR^

7,000 RPM
Senior Member

^pomen_GTR^

7,000 RPM
Senior Member
May 13, 2010
7,509
1,690
1,713
The Mines
yes..inside ISC also got thermostart to detect coolant temp. and adjust idle speed for quick warmup
 

sooyongng

Junior Member
Senior Member

sooyongng

Junior Member
Senior Member
Thread starter
Jun 16, 2010
5
1
503
Kuala Lumpur
Updated:12/5/2013 (ISC unit break down)
on 11/5/2013, while driving, RPM suddenly raise higher than usual.
When stop at traffic, RPM at 1.5, ON aircond, 2.0. Fully screw in idle screw also no help.
Next day, went to workshop and he plug in MUT, said ISC returns 0 reading.
And let him choppped for RM550, bottom part of throttle body, whole ISC unit, said is mmc original from taiwan.
No choice, my car cant use for daily drive if this problem persist.

After fix it, on idle, RPM at 600, ON aircond, RPM at 1100. the gap is bigger than before. which is 900 and 1100 only.
No vacuum leakage. part is brand new.
And one more thing, found PCV valve is leaking air, looks like stuck OPEN. currently seal the manifold intake from PCV, and let PCV valve open to atmosphere.
 

sooyongng

Junior Member
Senior Member

sooyongng

Junior Member
Senior Member
Thread starter
Jun 16, 2010
5
1
503
Kuala Lumpur
-------------------------------------------------------------
Updated:20/5/2013 (ISC unit break down AGAIN!)
In the early morning, when key turn to ON, no sound coming from ISC unit, means gear isn't moving.
Start car, and RPM like vroom vroom, up down up down very fast.
After few times testing, confirmed ISC not moving.
Get back to workshop, foreman direct changed new ISC unit (Bottom part). without repair it, cause it's still new and they can claim warranty.

Second ISC, when ON aircond, RPM still drop near to stall.
No choice, i have to plug in FICD to maintain RPM while A/C is ON.
Now starting suspect ECU that caused low RPM. will find one day and dismantle ECU to inspect.
 

sweelt

2,000 RPM

sweelt

2,000 RPM
Nov 6, 2016
2,292
246
663
Penang
my slot in question again. my wira 93T.
have all the symptom stated above at early part after swapping engine.
Some troubleshooting i do it myself. ISC replaced. TPS adjust according to online manuals (resistance continuity reading).
BISS screw adjustment made. Before change ISC, BISS near full open. Now fews round from close position.
Cold start 1500rpm slowly drop to 700-750rpm.
ON air-con rpm jump to 950rpm. Drop to 550rpm when compressor kick in, then up to 900rpm. ISC is working.

After drive for 1-2 hrs, normal one. OFF engine.

When start back the engine after 1/2hr (warm start), rpm stay low. 550-600rpm. vibrate.
ON air-con, all back to normal. OFF air-con, car idle normal.

I got read from pomen_gtr about oil filler cap leaking. Cause irregular idle.

Pls help me to continue further my diagnostic. Thanks sifu.
 
Last edited:

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,869
8,347
1,713
Petaling Jaya
my slot in question again. my wira 93T.
have all the symptom stated above at early part after swapping engine.
Some troubleshooting i do it myself. ISC replaced. TPS adjust according to online manuals (resistance continuity reading).
BISS screw adjustment made. Before change ISC, BISS near full open. Now fews round from close position.
Cold start 1500rpm slowly drop to 700-750rpm.
ON air-con rpm jump to 950rpm. Drop to 550rpm when compressor kick in, then up to 900rpm. ISC is working.

After drive for 1-2 hrs, normal one. OFF engine.

When start back the engine after 1/2hr (warm start), rpm stay low. 550-600rpm. vibrate.
ON air-con, all back to normal. OFF air-con, car idle normal.

I got read from vr2turbo about oil filler cap leaking. Cause irregular idle.

Pls help me to continue further my diagnostic. Thanks sifu.
Sure I quoted Oil Filler cap leaking cause irregular idle?:smokin:
 

sweelt

2,000 RPM

sweelt

2,000 RPM
Nov 6, 2016
2,292
246
663
Penang
Years back forum. My bad, is from pomen_gtr. :burnout:
Cooldown vr2turbo.:smokin:
Pls help. Why idle low on warm start.
 
Last edited:

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,869
8,347
1,713
Petaling Jaya
Anyway, you appear in that posting. wahlao...my face turn blue d.
Turn blue, breathe, breathe....hhahhaha

Hello, remember I size 11 you size 12 shoe, so I don't think I can attempt anything......hhahhahahhahhahahhahha :rofl::rofl:
 

sweelt

2,000 RPM

sweelt

2,000 RPM
Nov 6, 2016
2,292
246
663
Penang
my slot in question again. my wira 93T.
have all the symptom stated above at early part after swapping engine.
Some troubleshooting i do it myself. ISC replaced. TPS adjust according to online manuals (resistance continuity reading).
BISS screw adjustment made. Before change ISC, BISS near full open. Now fews round from close position.
Cold start 1500rpm slowly drop to 700-750rpm.
ON air-con rpm jump to 950rpm. Drop to 550rpm when compressor kick in, then up to 900rpm. ISC is working.

After drive for 1-2 hrs, normal one. OFF engine.

When start back the engine after 1/2hr (warm start), rpm stay low. 550-600rpm. vibrate.
ON air-con, all back to normal. OFF air-con, car idle normal.

I got read from pomen_gtr about oil filler cap leaking. Cause irregular idle.

Pls help me to continue further my diagnostic. Thanks sifu.
Dear sifu. Pls help me how to diagnose warm start low idle.
 

^pomen_GTR^

7,000 RPM
Senior Member

^pomen_GTR^

7,000 RPM
Senior Member
May 13, 2010
7,509
1,690
1,713
The Mines
Dear sifu. Pls help me how to diagnose warm start low idle.
there is another BSS screw inside the stepper motor...try re-adjust that first...make it almost closed...