front suspension rattle on uneven road

pac_jb

Known Member

pac_jb

Known Member
Feb 28, 2013
131
14
518
Kuala Lumpur
Hi,

My car having some problem , when go on uneven road or speed bumps , the car seems to be very bumpy/ rattle(even my dash board vibrates) but when on highway or smooth road its perfect. Using hwl hlsh adjustable absober but I recently noticed that I don't have the front top mounting for the aborbers , I have noticed some cars still use their oem top mount even though change to adjustable absorber, do I need this top mount installed?tq
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,878
8,347
1,713
Petaling Jaya
Hi,

My car having some problem , when go on uneven road or speed bumps , the car seems to be very bumpy/ rattle(even my dash board vibrates) but when on highway or smooth road its perfect. Using hwl hlsh adjustable absober but I recently noticed that I don't have the front top mounting for the aborbers , I have noticed some cars still use their oem top mount even though change to adjustable absorber, do I need this top mount installed?tq
Your suspension comes with pillow ball mount?
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,878
8,347
1,713
Petaling Jaya
Not that sure, attached the picture, mine look exactly like that
Yup, looks like yours is minus the original top mount. If you want better ride then ask mechanic to fit them back on. Original top mount have rubber cushion



This is my suspension. The black thing right on top is the original top mount of the absorber...:driver:
 

pac_jb

Known Member

pac_jb

Known Member
Thread starter
Feb 28, 2013
131
14
518
Kuala Lumpur
Ok bro..will check with my mechanic..if problem persist I think ill change back to standard abosrber...getting eterna tt Halfcut absorbers at good price . Cannot tahan the bumpiness , especially the yellow lines, car vibrate like hell like all going to cabut.
 

ken yeang

6,000 RPM
Senior Member

ken yeang

6,000 RPM
Senior Member
Feb 2, 2006
6,618
1,327
1,713
For the time being, put-put cushion on your seat...to absorb the bumpiness.
 

Tom

TIMETOATTACK
Helmet Clan

Tom

TIMETOATTACK
Helmet Clan
Jul 6, 2000
5,534
3,205
5,213
Kuala Lumpur
Could be one of these:
- your top mount bearing has worn out. a replacement bearing will solve it for sure, if you have trouble locating the source, suspension makers can get it done for you. However some might require you to replace the entire mount to suit their design. Try Titan Suspension located somewhere near kota damansara.
- you have adjusted the height of the car recently. It might have been done wrongly. Some preload is required when setting the height of the coilovers. Preload provides the slight compression in the spring to keep it taut.
- worse case, your suspension needs a service.
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,878
8,347
1,713
Petaling Jaya
Ok bro..will check with my mechanic..if problem persist I think ill change back to standard abosrber...getting eterna tt Halfcut absorbers at good price . Cannot tahan the bumpiness , especially the yellow lines, car vibrate like hell like all going to cabut.
Oh! if like that, lowered springs and adjustable suspension even with original rubber mount will still be bumpy like mine.....lol:biggrin: