Car couldn't Start Eventhough the Battery Was Fine

CLS78

Known Member

CLS78

Known Member
Aug 24, 2016
111
8
518
44
Petaling Jaya
Yesterday evening i encountered a problem that i've never encounter before...My Suzuki SX4 suddenly couldn't start....I've double checked the battery was fine....Lights can be lighted up....radio can be on.....air-conditioner can also be on...in fact everything was fine and nothing was wrong.....The petrol was half the tank...However, after cranking a number of times....the engine just wouldn't start....I had to towed the car to the workshop from home....The mechanic told me that the fuel didn't reached the engine to allow the spark plugs to spark the fuel for the engine to start....This has never happened before....

Does anyone knows what the problems might be?....Is this normal or a rare designated engine problems?....Do you think the mechanic was right about what his diagnosed was?.....Your opinion is much appreciated....Thanks :adore: :adore: :adore:
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,878
8,347
1,713
Petaling Jaya
Since already at the mechanic, he did not settle the issue? Looks like fuel pump or check the fuse first....
 

CLS78

Known Member

CLS78

Known Member
Thread starter
Aug 24, 2016
111
8
518
44
Petaling Jaya
he behaved as if he knew nothing and not knowing how to fix it....I'm kinda uneasy with this mechanic....do you have any good mechanics that you can recommend?....preferably Selangor or KL area....thanks

:adore: :adore: :adore:
 

6UE5t

6,000 RPM
Senior Member

6UE5t

6,000 RPM
Senior Member
Oct 8, 2010
6,730
1,293
1,713
Kuala Lumpur
Can be fuel pump or fuel pressure sensor problem. So even if the fuel pump still fine but if the pressure sensor already spoiled then that prevented the engine to start coz it tries to protect the engine.
 

^pomen_GTR^

7,000 RPM
Senior Member

^pomen_GTR^

7,000 RPM
Senior Member
May 13, 2010
7,509
1,690
1,713
The Mines
sure fuel didnt reach?


or was it crank sensor?
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,878
8,347
1,713
Petaling Jaya
he behaved as if he knew nothing and not knowing how to fix it....I'm kinda uneasy with this mechanic....do you have any good mechanics that you can recommend?....preferably Selangor or KL area....thanks

:adore: :adore: :adore:
Pm you the contact dy.....:driver:
 

CLS78

Known Member

CLS78

Known Member
Thread starter
Aug 24, 2016
111
8
518
44
Petaling Jaya
sure fuel didnt reach?


or was it crank sensor?
Its fuel didn't reach....got cranks...just would ignite to start the engine

Sent from my SM-N9005 using Tapatalk
 

CLS78

Known Member

CLS78

Known Member
Thread starter
Aug 24, 2016
111
8
518
44
Petaling Jaya
I've never encounter this problem with my other car before....this was the first...is it a normal with suzuki only or other cars can be infected too?

Sent from my SM-N9005 using Tapatalk
 

CLS78

Known Member

CLS78

Known Member
Thread starter
Aug 24, 2016
111
8
518
44
Petaling Jaya
Can try to send back to Suzuki service centre?
I was adviced not to send to suzuki service centre cos was told that their workmanship aren't that good....so searching for outside mechanics who expert with suzuki

Sent from my SM-N9005 using Tapatalk
 

sweelt

2,000 RPM

sweelt

2,000 RPM
Nov 6, 2016
2,292
246
663
Penang
Did u face any symptoms of need to crank longer than usual. Before this current issue occured.
Might be feul pump or weak battery.
 

Tom

TIMETOATTACK
Helmet Clan

Tom

TIMETOATTACK
Helmet Clan
Jul 6, 2000
5,534
3,205
5,213
Kuala Lumpur
Yesterday evening i encountered a problem that i've never encounter before...My Suzuki SX4 suddenly couldn't start....I've double checked the battery was fine....Lights can be lighted up....radio can be on.....air-conditioner can also be on...in fact everything was fine and nothing was wrong.....The petrol was half the tank...However, after cranking a number of times....the engine just wouldn't start....I had to towed the car to the workshop from home....The mechanic told me that the fuel didn't reached the engine to allow the spark plugs to spark the fuel for the engine to start....This has never happened before....

Does anyone knows what the problems might be?....Is this normal or a rare designated engine problems?....Do you think the mechanic was right about what his diagnosed was?.....Your opinion is much appreciated....Thanks :adore: :adore: :adore:
Try checking:
- Fuel Relay / Fuse
- If you are keen, unplug the fuel line from the rail and see if the fuel pumps when you turn on the ignition
- This symptom could also be caused by a faulty crank angle sensor (engine perfect but crank all day and no ignition)
 

CLS78

Known Member

CLS78

Known Member
Thread starter
Aug 24, 2016
111
8
518
44
Petaling Jaya
Did u face any symptoms of need to crank longer than usual. Before this current issue occured.
Might be feul pump or weak battery.
Yupp...i cranked for long time still couldn't start....this symptom never happened to me beforem...this was the first...

Sent from my SM-N9005 using Tapatalk
 

CLS78

Known Member

CLS78

Known Member
Thread starter
Aug 24, 2016
111
8
518
44
Petaling Jaya
Guys....problem fixed! the fuel line sensor was the culprit....i am lucky to get it fixed in a very low charges...now my suzuki is in good condition...thanks guys

Sent from my SM-N9005 using Tapatalk
 

6UE5t

6,000 RPM
Senior Member

6UE5t

6,000 RPM
Senior Member
Oct 8, 2010
6,730
1,293
1,713
Kuala Lumpur
Guys....problem fixed! the fuel line sensor was the culprit....i am lucky to get it fixed in a very low charges...now my suzuki is in good condition...thanks guys

Sent from my SM-N9005 using Tapatalk
Ah very good then, seems similar issue like I've mentioned earlier about the fuel pressure sensor malfunction.
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,878
8,347
1,713
Petaling Jaya
Guys....problem fixed! the fuel line sensor was the culprit....i am lucky to get it fixed in a very low charges...now my suzuki is in good condition...thanks guys

Sent from my SM-N9005 using Tapatalk
Good to hear that, now learn something new about your car too.....lol:driver:
 

RENESIS VIII

7,000 RPM
Senior Member

RENESIS VIII

7,000 RPM
Senior Member
Jun 13, 2012
7,060
948
713
Ipoh
Guys....problem fixed! the fuel line sensor was the culprit....i am lucky to get it fixed in a very low charges...now my suzuki is in good condition...thanks guys

Sent from my SM-N9005 using Tapatalk
Good to know that. Where did you send it to?
 

CLS78

Known Member

CLS78

Known Member
Thread starter
Aug 24, 2016
111
8
518
44
Petaling Jaya
Good to hear that, now learn something new about your car too.....lol:driver:
Yupp...definitely i learned something...thanks to you guys for the advice too

Sent from my SM-N9005 using Tapatalk
 

CLS78

Known Member

CLS78

Known Member
Thread starter
Aug 24, 2016
111
8
518
44
Petaling Jaya
Good to know that. Where did you send it to?
I was referred to a mechanic in taman mayang, PJ....he's quite an expert....he told me what was wrong and advice to only fix the particular problem only and not other unrelated stuffs...good job done and he's very honest with his work
Good to hear that, now learn something new about your car too.....lol:driver:

Sent from my SM-N9005 using Tapatalk
 

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator

vr2turbo

Beyond 20,000 RPM!
Helmet Clan
Moderator
May 11, 2010
29,878
8,347
1,713
Petaling Jaya
I was referred to a mechanic in taman mayang, PJ....he's quite an expert....he told me what was wrong and advice to only fix the particular problem only and not other unrelated stuffs...good job done and he's very honest with his work
Good to find an honest mechanic. Some will change this and that and still cannot find the problem and yet you get charged.....lol
 

CLS78

Known Member

CLS78

Known Member
Thread starter
Aug 24, 2016
111
8
518
44
Petaling Jaya
Good to find an honest mechanic. Some will change this and that and still cannot find the problem and yet you get charged.....lol
Thats why...i was lucky and glad that he was honest....

Sent from my SM-N9005 using Tapatalk
 

RENESIS VIII

7,000 RPM
Senior Member

RENESIS VIII

7,000 RPM
Senior Member
Jun 13, 2012
7,060
948
713
Ipoh
I was referred to a mechanic in taman mayang, PJ....he's quite an expert....he told me what was wrong and advice to only fix the particular problem only and not other unrelated stuffs...good job done and he's very honest with his work



Sent from my SM-N9005 using Tapatalk
Definitely someone experienced with good honesty. It is always good to meet this kind of mechanic.